excel - come poter fare dei vincoli coi menù a tendina?

Dovrei realizzare un calcolatore di preventivi.

Con vari menù a tendina devo poter fare delle selezioni che ne escludono altre, ad esempio avendo una tendina coi mesi ed una coi giorni,selezionando febbraio, i giorni devono partire da 1 ed arrivare a 28.

Questi vincoli, che saranno numeri, alla fine verranno elaborati matematicamente per poter eseguire dei calcoli. Come nel caso di un assicurazione, mi serve un menù dove possa scegliere la zona della città (es.: Milano città, Milano provincia) e, una volta fatta la selezione, mi visualizzi le tariffe solo per la zona indicata.

3 risposte

Classificazione
  • 1 decennio fa
    Risposta preferita

    wow, chiedi un mucchio di cose...

    partiamo dall'ultima:

    per creare un menù a tendina con Milano città, Milano provincia vai nella cella in cui vuoi che compaia la tendina (diciamo A1) poi vai su Dati->convalida dove c'è "qualsiasi valore" tu metti elenco e poi scrivi i nomi delle città che vuoi che compaiano separati da ;

    per i mesi puoi fare la stessa cosa mettendo però i nomi dei mesi sempre separati da ; (mettiamo che questo elenco sia nella casella B1)

    per i giorni la faccenda si complica... ci serve una colonna (che poi nasconderai, diciamo la colonna E), di questa colonna seleziona le celle da E1 a E31, dopodichè in alto a sinistra, nell'angolo dove vedi scritto E1 scrivici Giorni. a questo punto riempi le celle dal 1 al 28 con i numeri dall'1 al 28

    nella casella E29 scrivi: =SE(B1="Febbraio";"";29) stando attento che Febbraio e febbraio NON sono la stessa cosa quindi nel tuo elenco che hai fatto in B1 metti i mesi con la prima lettera maiuscola.

    Nella casella E30 scrivi =SE(B1="Febbraio";"";30)

    Nella casella E31 scrivi =SE((B1="Febbraio") + (B1="Novembre") + (B1="Aprile") + (B1="Giugno") + (B1="Settembre");"";31)

    a questo punto nella casella dove vuoi che compaia la tendina (mettiamo C1) vai su dati->Convalida->Elenco e scrivi =Giorni

    a questo punto puoi fare tutti i calcoli che vuoi

  • 1 decennio fa

    Per ogni dubbio ti consiglio il supporto online. trovi molte cose..

    http://office.microsoft.com/it-it/excel-help/

    Su google poi trovi molte guide anche perché spiegarlo diventa piuttosto lunga..

    http://www.oneitoffice.it/28/05/2009/menu-a-tendin...

    Una guida che ho trovato comoda e che mi ha insegnato molto è questa:

    http://www.pcdazero.it/2406_funzioni_excel.php

    Ciao.

  • Anonimo
    1 decennio fa

    abbracadabbraaaaaaaaaaa

Altre domande? Fai una domanda e ottieni le risposte che cerchi.