aiuto formula excel per calcolo valori generici in una griglia N x N?

ciao, qualcuno mi saprebbe dire quale formula usare per poter avere una cella che sommi il totale delle celle di una matrice la quale contiene dati generici?

ad esempio: supponiamo che io abbia una griglia N x N e in qualche cella pongo alcuni valori di carattere generico, necessito di sapere quante celle sono piene all' interno della griglia e il numero deve apparire su una cella di lato.

spero di essere stato chiaro.

grazie mille

1 risposta

Classificazione
  • 10 anni fa
    Risposta preferita

    Supponiamo che la tua griglia sia di 4 righe x 4 colonne nel range A1:D4.

    Per calcolare quante celle contengono un valore generico (sia di testo che numerico) scrivi:

    =CONTA.SE(A1:D4; "<>" & "")

    La funzione conta tutte le celle con contenuto diverso da cella vuota.

    L'operatore & di concatenazione serve per poter usare all'interno della condizione il valore di cella vuota "".

    Come controprova puoi anche contare le celle vuote con la seguente formula:

    =CONTA.SE(A1:D4; "")

    e verificare che la somma delle celle vuote e delle celle piene corrisponda al numero totale delle celle contenute nella tua griglia (in questo esempio A1:D4 = griglia 4x4 = 16 celle)

    Fonte/i: Professionista sviluppo SW ambienti Microsoft e Linux
Altre domande? Fai una domanda e ottieni le risposte che cerchi.