Autocad comando distanza?

Utilizzando il comando distanza, esiste la possibilità di avere una somma se mi occorre conoscere la lunghezza totale di più tratte insieme? Grazie.

2 risposte

Classificazione
  • 9 anni fa
    Risposta preferita

    Contrariamente al comando Area per cui è possibile aggiungere/sottrarre oggetti al calcolo dell'area, per il comando Distanza non si può ottenere un totale

    Se poi selezioni tutti gli oggetti come suggerito dall'altro utente, dal pannello proprietà Lunghezza troverai una scritta *Varie* che indica che le lunghezze sono tutte diverse e non c'è ombra del totale.

    Ci sono alcuni metodi:

    1) cercare una routine Autolisp per il calcolo della lunghezza con selezione multipla di oggetti (line, archi, polilinee), ne ho trovata qualcuna ma tutte hanno difetti: alcune richiedono di selezionare un oggetto alla volta, altre danno errori perchè funzionano solo con i comandi inglesi, ecc.

    2) altrimenti puoi usare il comando _dataextraction che trovi anche da menu Strumenti > Estrai data

    Questo comando permette di estrarre la proprietà desiderata , nel tuo caso lunghezza (volendo anche le coordinate di ogni punto, layer, tipolinea ecc.), a partire da una selezione oggetti oppure anche da tutto il disegno

    C'è un'autocomposizione che si fa una volta sola, questa permette di definire cosa esportare e in quale directory (viene creato un file .dxe riutilizzabile). Alla fine ottieni ad es. in Excel una colonna con tutte le lunghezze dei tratti selezionati, basta andare sull'ultima cella e scrivere, supponendo che i dati siano in colonna A dalla riga 0 alla 100

    =SOMMA(A1:A100)

    C'è solo un piccolo problema di esportazione in quanto le lunghezze vengono esportate come

    '100.00

    '2000.23

    '234.05

    cioè viene messo un apice all'inizio e il punto decimale invece della virgola, ma è sufficiente operare una ricerca e sostituzione ad es. nel blocco notes aprendo il file csv e poi farlo leggere da Excel a modifica ottenuta. Alla successiva estrazione dati è possibile riutilizzare il file .dxe senza dover reimpostare tutto

    3) Ultimo caso, copi le tratte mettendole in fila una all'altra con il punto finale di una tratta che coincide con quello iniziale della successiva, poi da il comando _PEDIT, selezioni la prima tratta o linea e converti in polilinea se non lo è già, usi poi il comando _JOIN per unire tutte le altre tratte selezionandole con una unica finestra. Se tutto va bene ottieni un'unica polilinea e dal pannello Proprietà - Lunghezza vedrai il totale che ti interessa

  • 9 anni fa

    Si selezionale tutte e vai su proprietà, cercando tra i vari parametri troverai la lunghezza

    Se vuoi approfondire seriamente le tue conoscenze con AutoCAD scarica questo video corso:

    http://corsoautocad.altervista.org/

Altre domande? Fai una domanda e ottieni le risposte che cerchi.