Anonimo
Anonimo ha chiesto in Computer e InternetSoftware · 6 anni fa

calcolo media excel?

Avrei bisogno di calcolare la media di alcune celle, so la cella iniziale, ma la cella finale deve corrispondere ad un valore calcolato con conta.valori.

una cosa del genere =media(B1:BX)

Dove X =conta.valori(A1:A7; "U")

Quindi se ci sono i valori nella colonna A, lui fa la media da B1 fino al valore BX

questa la mia griglia:

A B C

1 U 1

2 U 2

3 U 5

4 U 8

5

6

7

help me

2 risposte

Classificazione
  • Anonimo
    6 anni fa
    Risposta preferita

    Devi usare la funzione INDIRETTO

    se vuoi la formula specifica, o posta il file o mandamelo per email:

    crono.answers@hotmail.it

    • Commenter avatarAccedi per rispondere alle risposte
  • 6 anni fa

    Ciao

    se ho capito bene tu vuoi fare la media dei valori della seconda colonna solo se nella prima colonna c'è un valore, allora puoi usare la funzione media.se

    =media.se(A1:A7;">0";B1:B7)

    dove se nella colonna che va da A1 a A7 c'è un valore

    fa la media nella colonna accanto, la colonna B

    altrimenti quello che chiedi te si fa con la seguente funzione (più complicato ma stesso effetto)

    =MEDIA(B1:INDIRETTO("B"&CONTA(A1:A7)))

    tramite la funzione indiretto crei una stringa composta da B e il numero risultante dal conteggio dei valori nella colonna A. Questa strina si può usare come riferimento della formula della media

    ciao

    http://www.excellomane.it

    • Commenter avatarAccedi per rispondere alle risposte
Altre domande? Fai una domanda e ottieni le risposte che cerchi.