EXCEL: SOMM.SE con date?

C'è modo di indicare nel criterio di SOMMA.SE che la parola ricercata deve essere estrapolata da una data?

Ho necessità di fare delle somme di importi compresi in certi anni.

Sto usando la funzione SOMMA.SE in questo modo:

=SOMMA.SE(B2:B286;"*2008*";G2:G286)

il problema è che le celle nella colonna B sono formattate come DATA e non ottengo nessun risultato. Ho provato a formattare alcune caselle di B come TESTO ed inserire un testo a caso con inclusa la parola 2008 e il calcolo funziona. Se seleziono le caselle e semplicemente le converto da DATA a TESTO, la data contenuto viene convertita in un numero che non mi interessa (per esempio 30/09/2014 diventa 41912).

1 risposta

Classificazione
  • 6 anni fa
    Risposta preferita

    Ciao... le date sono spesso fonte di problemi.

    Dovresti utilizzare una formula matriciale; la formula è questa:

    =SOMMA(SE(ANNO(B2:B286)=2008; G2:G286;0))

    dopo averla digitata o copiata devi necessariamente uscire dalla cella con questa combinazione di tasti:

    CTRL+SHIFT+INVIO

    e la formula verrà messa tra parentesi quadre. Se lungo la colonna B ci sono date nell'anno 2008 verrà sommata la relativa cella nella colonna G

Altre domande? Fai una domanda e ottieni le risposte che cerchi.